3
Vote

Slideshow worked with DNN 6.02 but not with 6.1.0

description

I installed Gallery with DNN 6.01 and 6.02 and it worked fine. I have just upgraded to 6.1.0 and unfortunately the slideshow no longer works. The window opens but the image does not display.
 
See www.vintagebus.org/LFM734/Oct2011.aspx

comments

nosecam wrote Nov 15, 2011 at 6:24 AM

Same here. In addition, the non-popup slideshow is totally misplaced

imagemaker wrote Nov 19, 2011 at 4:27 PM

I was able to reproduce the popup slideshow failure in both DNN 6.01.00 and 6.01.01. It had worked fine in the DNN 6.01.00 BETA. Fiddler shows that the javascript file Gallery/Popup/GalleryPopup.js is not loading due to a Http 404 (not found) error even though its URL is correct. My best guess at this time is that the new Client Resource Management/Client Dependency features introduced in DNN 6.01.00 are the cause of this issue but need to do further testing and get a better understanding of the Client Resource Management feature.

I was not able to reproduce the scrambled display of the non-popup slideshow when using the DNN 6 Dark Knight skin and containers. Nosecam -- please advise if you are using a legacy skin and if you can reproduce this issue witht he default DNN 6 Dark Knight skin/containers.

nosecam wrote Nov 19, 2011 at 6:28 PM

I used the default DNN 6 Dark Night skin/containers. Due to the problems I removed this gallery from my page, although I liked it in the first place :-(

imagemaker wrote Nov 22, 2011 at 3:33 AM

Further analysis of the issue showed that the jQuery framework required for the Slideshow is not loading when pop-ups are enabled in the Gallery configuration. With the introduction of the core ClientDependencyManagement API and in particular a change in how external script tags are injected into the page header in DNN 6.01.00 and 6.01.01, there is no simple work-around for this issue short of modifying, recompiling, and re-packaging the Gallery module. Since I plan to concentrate on building an all new Gallery 5 (or more likely a Gallery 6) module not based on Gallery 3/4.xx legacy code, I will have to mark this issue as "won't fix".